Меню
Индекс

Обмен данных с 1С

Примечание: «Связь с программой 1С: Предприятие» — это дополнительный модуль, который приобретается отдельно. Инструкции в данном разделе актуальны, если конфигурация программы включает модуль «Связь с 1С».
 
Данная возможность позволяет осуществлять перенос данных из TransTrade в 1С: Предприятие и наоборот — из 1С: Предприятие в TransTrade. Обмен предусмотрен для следующих данных:
·     Клиенты
·     Исполнители
·     Платежные документы (счета, счета-фактуры, акты)
·     Поступление услуг
 
Механизм обмена: в одной программе выбираем, что нужно перенести, и выгружаем данные в обменный файл. А в другой программе загружаем этот файл и принимаем данные. Формат обменного файла — XML.
Поддерживаемые версии платформы 1С: Предприятие: 7.7, 8.1, 8.2, 8.3.
Конфигурация: «Бухгалтерия предприятия», редакция 2.0 и 3.0.
 
Работа с данными осуществляется при помощи специального интерфейса — как в TransTrade, так и в 1С: Предприятие. Окно обмена имеет две вкладки верхнего уровня: «Загрузка» и «Выгрузка», внутри которых уже выбирается вкладка с нужными данными и регулируются параметры обмена. А на самой вкладке с данными — определяется набор данных для переноса.
Для того чтобы открыть окно обмена данных в TransTrade, воспользуйтесь следующей командой главного меню:
 
БУХГАЛТЕРИЯ → Обмен с 1С / F12
 
 
Файл — имя обменного файла для загрузки (выгрузки) данных. По умолчанию местонахождение обменных файлов — на диске С.
Указать — выбрать другой обменный файл.
Фирма — ваша организация, по которой необходимо производить обмен. Данное поле доступно только при наличии дополнительного модуля «Мульти Фирма».
Обновлять контрагентов — опция, разрешающая обновлять реквизиты существующих контрагентов при их повторной загрузке.
 
 
Период документов — диапазон дат выписанных платежных документов и перевозок.
Подробное описание услуг — переносить подробные описания услуг, согласно установленному формату формулировок.
Отметить все — включить (выключить) все позиции для загрузки/выгрузки.
Обновить данные — актуализация данных в текущих таблицах.
 
Используемые по умолчанию имена обменных файлов:
Имя файла
Направление
Переносимые данные
1C_CLT_TT.xml
1С → TransTrade
Клиенты
1C_DOC_TT.xml
1С → TransTrade
Платежные документы
1C_WRK_TT.xml
1С → TransTrade
Исполнители
TT_CLT_1C.xml
TransTrade →1С
Клиенты
TT_DOC_1C.xml
TransTrade →1С
Платежные документы
TT_WRK_1C.xml
TransTrade →1С
Исполнители
TT_BUY_1C.xml
TransTrade →1С
Поступление услуг (перевозки)
 
Для того чтобы открыть окно обмена данных в, выполните следующие действия:
 
1. Узнайте версию вашей платформы 1С: Предприятие и номер редакции конфигурации Бухгалтерия предприятия при помощи команды: «Показать информацию о программе» или «О программе» в меню Справка.
Справка → О программе
 
2. В папке с программой TransTrade находится папка «Связь с 1С», внутри которой имеются файлы обработок для разных версий . В зависимости от вашей версии , найдите и используйте соответствующий файл внешней обработки:
Версия 1С
Файл обработки
7.7
1C_TransTrade_77.ert
8.1
1C_TransTrade_81.epf
8.2, 8.3 – редакция 2.0
1C_TransTrade_82_83_БП-20.epf
8.2, 8.3 – редакция 3.0
1C_TransTrade_82_83_БП-30
 
 
3. Откройте этот файл в при помощи следующей команды главного меню:
 
Файл → Открыть / Ctrl + O
 
Или путем перетаскивания файла из папки «Связь с 1С» в программу :
 
 
Окно обмена данных в имеет похожий по смыслу интерфейс:
 
Имя файла — имя обменного файла для загрузки (выгрузки) данных. По умолчанию местонахождение обменных файлов — на диске С.
Организация — ваша фирма, по которой необходимо производить обмен.
 
А также одноименные вкладки с данными:
 
 
TransTrade : пошаговые инструкции переноса данных
Клиенты
1. TransTrade → Выгрузка → Клиенты
2. Отметить выгружаемых контрагентов
3. Нажать кнопку «Выгрузить»
4. → Загрузка → Контрагенты
5. Отметить загружаемых контрагентов
6. Нажать кнопку «Загрузить контрагентов»
Исполнители
1. TransTrade → Выгрузка → Исполнители
2. Отметить выгружаемых контрагентов
3. Нажать кнопку «Выгрузить»
4. → Загрузка → Контрагенты
5. Отметить загружаемых контрагентов
6. Нажать кнопку «Загрузить контрагентов»
Платежные документы
1. TransTrade → Выгрузка → Документы
2. Отметить выгружаемые документы
3. Нажать кнопку «Выгрузить»
4. → Загрузка → Документы
5. Отметить загружаемые документы
6. Нажать кнопку «Загрузить документы»
Перевозки: поступление
услуг
1. TransTrade → Выгрузка → Перевозки
2. Отметить выгружаемые заказы
3. Нажать кнопку «Выгрузить»
4. → Загрузка → Поступление ТМЗ Услуг
5. Отметить загружаемые перевозки
6. Нажать кнопку «Загрузить документы поступления»
 
TransTrade: пошаговые инструкции переноса данных
Клиенты
1. → Выгрузка → Выгрузка контрагентов
2. Выбрать группу контрагентов (при необходимости)
3. Нажать кнопку «Выбрать контрагентов»
4. Отметить выгружаемых контрагентов
5. Нажать кнопку «Выгрузить контрагентов»
6. TransTrade → Загрузка → Клиенты
7. Отметить загружаемых контрагентов
8. Нажать кнопку «Загрузить»
Исполнители
1. → Выгрузка → Выгрузка контрагентов
2. Выбрать группу контрагентов (при необходимости)
3. Нажать кнопку «Выбрать контрагентов»
4. Отметить выгружаемых контрагентов
5. Нажать кнопку «Выгрузить контрагентов»
6. TransTrade → Загрузка → Исполнители
7. Отметить загружаемых контрагентов
8. Нажать кнопку «Загрузить»
Платежные документы
1. → Выгрузка → Выгрузка документов
2. Указать период выбора документов
3. Нажать кнопку «Выбрать документы»
4. Отметить выгружаемые документы
5. Нажать кнопку «Выгрузить документы»
6. TransTrade → Загрузка → Документы
7. Отметить загружаемые документы
8. Нажать кнопку «Загрузить»